Page 1 of 1

Turbo Stabilizer Video Won't Play

PostPosted: Sun Jun 29, 2014 4:49 pm
by GDGerlach344
I'm trying the trial version of Turbo Video Stabilizer and created a stabilized Mp4 file but it won't play in Windows Media Player, Quicktime or SpeedEdit, my professional video editing software. Can't use this product if I can't play the videos. Any suggestions?

I'm using it on a PC running Windows 7 Professional.

Re: Turbo Stabilizer Video Won't Play

PostPosted: Tue Jul 01, 2014 5:47 am
by patrick
Hi GDGerlach344,

Sorry to hear that you're having issues with the output. May we know the model of the camera that you used to capture the video clip from? Did you used any third party tool to compress the video clip before importing into the program?

Re: Turbo Stabilizer Video Won't Play

PostPosted: Thu Jul 03, 2014 3:29 am
by GDGerlach344
The video clip was straight out of a GoPro Hero 3 Black edition. I did not run it through any 3rd party software. I rendered out both a .mov and .mp4 file out of Turbo Stabilizer and cannot get either clip to play in any video player. Do I need to install a codec to make it work?

Re: Turbo Stabilizer Video Won't Play

PostPosted: Thu Jul 31, 2014 10:30 am
by patrick
Hi GDGerlach344,

When we launched Turbo Video Stabilizer, the GoPro Black Edition was not out yet, so we did not test thoroughly with 1080p 60FPS. Stabilizer will work with 1080p 60 FPS but in many cases we find that users run out of memory. This is inexcusable and unacceptable and we are finding a workaround and working on a fix with our partners. Unfortunately, its taking longer than expected. May we ask for your patience and we will post updates as soon as its fully tested and ready. Meanwhile, we have tested 1080p 30FPS and they work fine.